jammr Forum

Home of the jammr Community

  • You are not logged in.

#1 April 15, 2020 16:01:07

eb_liveDrums
Registered: 2020-04-11
Posts: 33
Reputation: +    -
Profile   Send e-mail  

Fix audio mix/lag when using multiple VSTi (disable audio in while monitoring)

First off, thanks for making a great tool for jamming. I recently taught a class at my work on how to use Jammr, delayed jamming, etc, and had a great response.

When using two vst instruments, say a drum machine and a fender rhodes sim, you have to set both plugins to “mix” and turn on input monitoring (“play my audio through”). This causes two problems. First, it mixes in the analog input from your interface, which you may not want. This can be solved if you have an audio interface, but if you’re using system audio you may be stuck with your built in mic audio being transmitted. This could be solved by adding a “none” option to the audio input, or alternately, having a separate checkbox to monitor the soft synths.

The second problem is much worse. When monitoring local analog audio with soft synths in “mix” mode, your send audio becomes out sync with the jam. I spent time with a friend, each of us playing just downbeats, and confirmed that this is the case. Outgoing audio is at least an 8th note out of sync. This is a real bummer, because using a soft synth drum machine with analog input would be very useful, but you can’t hear the drum machine without turning input monitoring on. This might be solved if it was possible to monitor soft synths without mixing in analog input, but you will probably have to test.

For reference this issue was found and tested on a windows 10 machine.

Offline

#2 April 15, 2020 16:15:45

eb_liveDrums
Registered: 2020-04-11
Posts: 33
Reputation: +    -
Profile   Send e-mail  

Fix audio mix/lag when using multiple VSTi (disable audio in while monitoring)

One additional request: fix or add MIDI clock to the MIDI OUT port. The checkbox to keep things in sync only seems to work with soft synths, I don’t see any MIDI realtime messages at the output port no matter what I do.

Add a button near the send/metronome buttons to enable midi start at the beginning of each interval, that way you could sync a DAW like ableton. It should be a button in the regular UI because you’re going to need it once in a while, like when the tempo changes or you get disconnected and have to reconnect.

Offline

#3 April 16, 2020 17:48:27

stefanha
Registered: 2012-11-11
Posts: 1685
Reputation: +    -
Profile   Send e-mail  

Fix audio mix/lag when using multiple VSTi (disable audio in while monitoring)

eb_liveDrums
I recently taught a class at my work on how to use Jammr, delayed jamming, etc, and had a great response.

That's awesome, thanks for sharing jammr with others!

eb_liveDrums
When using two vst instruments, say a drum machine and a fender rhodes sim, you have to set both plugins to “mix” and turn on input monitoring (“play my audio through”). This causes two problems. First, it mixes in the analog input from your interface, which you may not want. This can be solved if you have an audio interface, but if you’re using system audio you may be stuck with your built in mic audio being transmitted. This could be solved by adding a “none” option to the audio input, or alternately, having a separate checkbox to monitor the soft synths.

Have you tried setting the Audio routing option of the first plugin to “On” and the second plugin to “Mix”? Then you should only hear the plugins, not the audio input because the first plugin will only send its output and not the analog input from the interface. This works because effects plugins are in a chain - the output of one is the input of the next one.

eb_liveDrums
The second problem is much worse. When monitoring local analog audio with soft synths in “mix” mode, your send audio becomes out sync with the jam. I spent time with a friend, each of us playing just downbeats, and confirmed that this is the case. Outgoing audio is at least an 8th note out of sync. This is a real bummer, because using a soft synth drum machine with analog input would be very useful, but you can’t hear the drum machine without turning input monitoring on. This might be solved if it was possible to monitor soft synths without mixing in analog input, but you will probably have to test.For reference this issue was found and tested on a windows 10 machine.

Which VST plugin did you run?

Offline

#4 April 16, 2020 17:50:56

stefanha
Registered: 2012-11-11
Posts: 1685
Reputation: +    -
Profile   Send e-mail  

Fix audio mix/lag when using multiple VSTi (disable audio in while monitoring)

eb_liveDrums
One additional request: fix or add MIDI clock to the MIDI OUT port. The checkbox to keep things in sync only seems to work with soft synths, I don’t see any MIDI realtime messages at the output port no matter what I do.

Add a button near the send/metronome buttons to enable midi start at the beginning of each interval, that way you could sync a DAW like ableton. It should be a button in the regular UI because you’re going to need it once in a while, like when the tempo changes or you get disconnected and have to reconnect.

Thank you for these suggestions, I have added them to the todo list.

Offline

#5 April 16, 2020 20:55:40

captaincancel
Registered: 2020-04-12
Posts: 60
Reputation: +    -
Profile   Send e-mail  

Fix audio mix/lag when using multiple VSTi (disable audio in while monitoring)

eb_liveDrums
One additional request: fix or add MIDI clock to the MIDI OUT port. The checkbox to keep things in sync only seems to work with soft synths, I don’t see any MIDI realtime messages at the output port no matter what I do.Add a button near the send/metronome buttons to enable midi start at the beginning of each interval, that way you could sync a DAW like ableton. It should be a button in the regular UI because you’re going to need it once in a while, like when the tempo changes or you get disconnected and have to reconnect.

That's what I observed (or actually, didn't observe) with MidiOx. Still, there has to be some kind of a clock being sent, because if I set the output to my REV2, it's digital display does show the jam session's BPM, or close to it: room was set to 95, REV2 was seeing 96, but it would flicker up to 102 every once in a while.

Offline

#6 April 16, 2020 21:41:34

eb_liveDrums
Registered: 2020-04-11
Posts: 33
Reputation: +    -
Profile   Send e-mail  

Fix audio mix/lag when using multiple VSTi (disable audio in while monitoring)

captaincancel

On PC I see no messages, clock or otherwise, from the jammr midi out.

On MacOS, I can clock to Ableton Live using IAC, but the clock drifts ahead of the JAMMR metronome.

stefanha

https://www.kvraudio.com/product/mt-power-drum-kit-by-manda-audio

https://www.kvraudio.com/product/keyzone-classic-by-bitsonic

Offline

#7 April 16, 2020 23:08:05

captaincancel
Registered: 2020-04-12
Posts: 60
Reputation: +    -
Profile   Send e-mail  

Fix audio mix/lag when using multiple VSTi (disable audio in while monitoring)

eb_liveDrums

Strange.

I wonder if there is a MIDI router/clock VST that we could load that would then relay clock to a USB device (MIDI interface, direct USB to a synth/sequencer, etc.).

Offline

Board footer

Moderator control

Powered by DjangoBB

Lo-Fi Version