jammr Forum

Home of the jammr Community

  • You are not logged in.

#1 June 6, 2013 20:10:09

stefanha
Registered: 2012-11-11
Posts: 1116
Reputation: +  9  -
Profile   Send e-mail  

Tutorial: Getting low-latency audio on Windows

jammr supports several different audio systems on Windows, depending on the sound card your computer has. The older sound systems are compatible with most machines but have noticable lag - they are bad at real-time audio.

This is a quick tutorial on setting up low-latency audio:

1. If possible, choose the “WDM Kernel Streaming” audio system from the “File” | “Configure audio…” dialog. This usually produces good results.
2. Otherwise, choose the “WASAPI” audio system and select the recording (input) and playback (output) devices you wish to use.
3. If you are unable to join jams or see an “Failed to start audio” error message, right-click on the speaker icon in the bottom right corner of the screen in the task bar and select “Playback devices”.
4. Choose your device from the list and click “Properties”.
5. Then click “Advanced” and note the audio format (for example, “24 bit, 44100 Hz”).
6. Now repeat this for “Recording devices” instead of “Playback devices” and select formats on the recording and playback devices that match. This will ensure that jammr to use the playback and recording devices together.

We recommend selecting 24 bit and 48000 Hz. If the devices do not support this format, try 16 bit and 44100 Hz. The important thing is to use the same format for both the playback and recording devices.

When you have this set up you should notice that you feel no delay between when your fingers play notes on your instrument and when you hear the notes.

Offline

#2 June 9, 2013 14:24:18

NakajimaYusuke
From: Japan
Registered: 2013-06-04
Posts: 1
Reputation: +  0  -
Profile   Send e-mail  

Tutorial: Getting low-latency audio on Windows

Thank you for your e-mail, Stefan.

I am sorry that I did not reply sooner to you.
Because,I am very poor at English. Translation is time-consuming work for me.

I write to a forum so that a problem and its solution can be shared.

This is the action reporting in an old version.
These problems may be solved in the new version.
I have not tried the new version in detail. I will try it, soon.

My first problem is this.

I chose “WASAPI” as “Audio system”.
Then, “Input device” and “Output device” were not displayed.

http://forum.jammr.net/topic/4/
I followed these directions.

About “Sample rate” and “Bit rate”, I arranged “Recording devices” and “Playback devices” equally.
However, the result was the same.

Moreover, I tried various combination for “Sample rate” and “Bit rate”.

Example,

Playback devices 44100 Hz 16 bit
Recording devices 44100 Hz 16 bit

Playback devices 48000 Hz 16 bit
Recording devices 48000 Hz 16 bit

Playback devices 44100 Hz 24 bit
Recording devices 44100 Hz 24 bit

Playback devices 48000 Hz 24 bit
Recording devices 48000 Hz 24 bit

However, the result was the same.
“Input device” and “Output device” do not still appear.

If I select blank“Input device” and “Output device” and enter the room,The result is this.


I checked that the WASAPI operated normally in “Reaper” and “foobar2000”.

And, I checked log.txt.(In new version.)
It saids this.
6 09 2013 14:00:26 DEBUG: Trying Pa_OpenStream() with sampleRate 44100 inputLatency 0.0029 outputLatency 0.0029 innch 1 outnch 1
6 09 2013 14:00:26 DEBUG: Input device:  (Windows WASAPI)
6 09 2013 14:00:26 DEBUG: Output device:  (Windows WASAPI)
6 09 2013 14:00:26 CRIT: Pa_OpenStream() failed: Invalid number of channels
6 09 2013 14:00:26 CRIT: create_audioStreamer_PortAudio() failed


My second problem is this.

I chose “WDM-KS” as “Audio system”.
Then, I felt the intolerable noise.

This noise resembled the noise when the buffer size of ASIO was lowered.
I think that the cause of this noise is because the buffer size of “WDM-KS” is too small.

Reaper can adjust the buffer size of “WDM-KS”.
This noise will be able to be erased if this adjustment is possible at jammr.


I am using these equipment.
win7 64bit
FocusriteSaffire 6 USB(Old Type)
VOX Tonelab ST
Line6 Toneport UX1

I expect that this project will become good.
please do your best.

Offline

#3 June 10, 2013 15:58:57

stefanha
Registered: 2012-11-11
Posts: 1116
Reputation: +  9  -
Profile   Send e-mail  

Tutorial: Getting low-latency audio on Windows

NakajimaYusuke
Because,I am very poor at English. Translation is time-consuming work for me.

Thank you for replying and sharing details! The WDM KS problem should be fixed now, see below for more information.

NakajimaYusuke
My first problem is this.

I chose “WASAPI” as “Audio system”.
Then, “Input device” and “Output device” were not displayed.

And, I checked log.txt.(In new version.)
It saids this.
6 09 2013 14:00:26 DEBUG: Trying Pa_OpenStream() with sampleRate 44100 inputLatency 0.0029 outputLatency 0.0029 innch 1 outnch 1
6 09 2013 14:00:26 DEBUG: Input device:  (Windows WASAPI)
6 09 2013 14:00:26 DEBUG: Output device:  (Windows WASAPI)
6 09 2013 14:00:26 CRIT: Pa_OpenStream() failed: Invalid number of channels
6 09 2013 14:00:26 CRIT: create_audioStreamer_PortAudio() failed

Unfortunately this problem is probably still present in jammr 1.0.2. In the future jammr will support stereo and multi-channel sound cards. Until then, you may find WASAPI cannot be used with your hardware.

NakajimaYusuke
My second problem is this.

I chose “WDM-KS” as “Audio system”.
Then, I felt the intolerable noise.

This noise resembled the noise when the buffer size of ASIO was lowered.
I think that the cause of this noise is because the buffer size of “WDM-KS” is too small.

Reaper can adjust the buffer size of “WDM-KS”.
This noise will be able to be erased if this adjustment is possible at jammr.

I think that the WDM KS problem is now fixed in jammr 1.0.2 and later:
http://jammr.net/download.html

In jammr 1.0.2 you can set the sample rate and latency (buffer size). If you experience audio glitches (pops, clicks, noise) you can try increasing the latency setting to solve the problem.

Offline

#4 April 13, 2015 17:42:13

him3
Registered: 2015-04-13
Posts: 2
Reputation: +  0  -
Profile   Send e-mail  

Tutorial: Getting low-latency audio on Windows

Hi, some of the people in our session are hearing a one bar echo of everything that is played. Have you come across this problem/do you know how to fix it? Thanks!

Offline

#5 April 14, 2015 11:56:56

stefanha
Registered: 2012-11-11
Posts: 1116
Reputation: +  9  -
Profile   Send e-mail  

Tutorial: Getting low-latency audio on Windows

him3
Hi, some of the people in our session are hearing a one bar echo of everything that is played. Have you come across this problem/do you know how to fix it? Thanks!

Hi him3,
Is one of the users using a microphone that is picking up the sound from the speakers?

Stefan

Offline

Board footer

Moderator control

Powered by DjangoBB

Lo-Fi Version